1. Are you a current member with account or password issues?

    Please visit following page for more information

    Dismiss Notice

Streamlight ProTAC AAA issue

Discussion in 'Flashlights & Other Illumination Devices' started by duqjeep2010, Nov 23, 2013.

  1. duqjeep2010

    duqjeep2010 Loaded Pockets

    Joined:
    Aug 18, 2013
    Messages:
    63
    Likes Received:
    53
    So I thought I would share the issue that I encountered with my ProTAC 2AAA model last night.

    I went to the annual light up night holiday festivities here in the Burgh last night. I saw a co-worker whom was working the event and he dropped his keys so I pulled out my light to help him look and it wouldn't turn on. I checked all the connections made sure it was tightly screwed down and still no go. I then tucked it in my waist band to warm up and after ~5 minutes it worked fine. It had new Energizer batteries in it and it wasn't even that cold only around 40 out.

    Just thought I would share my experience with it.
     
  2. Kinzei
    • In Omnia Paratus

    Kinzei EDC Junkie

    Joined:
    May 15, 2013
    Messages:
    324
    Likes Received:
    3,646
    Thanks for the heads up. I carry one as my EDC light at work, and have not had any issues thus far, but I'm in Texas and it might finally get into the low 40's or upper 30's this weekend. I'll check and see if I have similar issues and report back.
     
  3. Xiii
    • In Omnia Paratus

    Xiii Loaded Pockets

    Joined:
    Sep 11, 2013
    Messages:
    1,386
    Likes Received:
    1,741
    is that the switch or the electronics that caused the problem?
    Xiii
     
  4. Tesla

    Tesla Loaded Pockets

    Joined:
    Apr 23, 2009
    Messages:
    846
    Likes Received:
    683
    If it worked when the batteries were warmed, I'd say it's temperature-related. Have you tested the batteries? I've gotten duds before out of a new batch of alkalines. I recommend L92 lithiums for high drain lights, anyway. They won't let you down in scenarios like you describe.
     
  5. duqjeep2010

    duqjeep2010 Loaded Pockets

    Joined:
    Aug 18, 2013
    Messages:
    63
    Likes Received:
    53
    I really think it is the electronics or switch causing the problem. The light would turn on when I clicked the switch however it would come on as strobe for a couple seconds then shut off. It did the same thing every time until it warmed up.
     
    Nkelly226 likes this.
  6. Syclone

    Syclone Loaded Pockets

    Joined:
    Aug 26, 2012
    Messages:
    1,506
    Likes Received:
    6,781
    That sounds like the battery to me.
     
  7. Nkelly226

    Nkelly226 Loaded Pockets

    Joined:
    May 21, 2013
    Messages:
    521
    Likes Received:
    1,062
    I have the same light and it had a short, contact streamlight and they will tell you about local dealers who can fix it or you can send it in their customer service is beyond great I must say, I've lost two tailcap switch boots and each time they've sent me brand new complete tailcaps