1. Are you a current member with account or password issues?

    Please visit following page for more information

    Dismiss Notice

Problem with the Show Unread Posts Since Last Visit option

Discussion in 'Forum Issues' started by captainamerica, May 6, 2009.

  1. captainamerica

    captainamerica Loaded Pockets

    Joined:
    Apr 21, 2009
    Messages:
    234
    Likes Received:
    92
    The "show unread posts since last visit" option doesn't work every time I log in or revisit the site. At this point it works 60 to 75 percent of the time. The other times I can look at new posts one section at at time; which is very time consuming. Any ideas? Thank you.
     
  2. FeebleOldMan

    FeebleOldMan Loaded Pockets

    Joined:
    Feb 10, 2009
    Messages:
    671
    Likes Received:
    11
    Hmm.. When you say it doesn't work, what do you mean? The page does not load? Or it doesn't show any unread posts?
     
  3. noth

    noth Loaded Pockets

    Joined:
    Sep 16, 2008
    Messages:
    145
    Likes Received:
    1
    At the "unread posts" page, click on the "show all unread topics" link (or append ';all' to the URL, without the quotes of course).
     
  4. Valerian

    Valerian Tea-powered admin

    Joined:
    Jul 20, 2007
    Messages:
    6,266
    Likes Received:
    2,019
    I'd also like to know what exactly you mean with "doesn't work".

    One possibility that came up before was that if you don't log out when you leave, there will be no new posts since last visit, since the software thinks you've been here all the time. IOW, if you stay logged in all the time, there's no "last visit".
     
  5. Synaptic Misfire
    • In Omnia Paratus

    Synaptic Misfire Loaded Pockets

    Joined:
    Nov 15, 2008
    Messages:
    1,228
    Likes Received:
    246
    Its bugged has been since I've been here I just learned to live with it. I think the cookies are expiring too quickly so it has no last visit stamp. It works fine as long as I am in the same browser session or it has been less than a few hours otherwise I get no new posts.
     
  6. noth

    noth Loaded Pockets

    Joined:
    Sep 16, 2008
    Messages:
    145
    Likes Received:
    1
    "It's not a bug; it's a feature"... :) It would be a bug if new posts didn't show up even under the "all unread topics" (not "unread posts since last visit") option, which they however do.
     
  7. captainamerica

    captainamerica Loaded Pockets

    Joined:
    Apr 21, 2009
    Messages:
    234
    Likes Received:
    92
    Specifically I find that there are times that I close the window (not logging off, just closing the window/site) after reading all new posts, etc. and later the same day and even after overnight I return to the site and get no new posts. To read new posts I go back to the front page and select each section that I want to look in one at a time. Inside these sections I will get a new posts indicator where applicable. It seems to happen 1 in 4 or 1 in 5 visits but since I'm new as of a few weeks ago I don't really have any set pattern on this; just the fact that it is more of a pain than anything.
     
  8. Synaptic Misfire
    • In Omnia Paratus

    Synaptic Misfire Loaded Pockets

    Joined:
    Nov 15, 2008
    Messages:
    1,228
    Likes Received:
    246
    Nothing shows up, not even under the all unread topics. This has been brought up before and nothing has been done so I just deal with it. It just did this when I came to the site nothing under either unread posts options and you can see the time stamp from the above post of when I was here last.
     
  9. Smokey

    Smokey Empty Pockets

    Joined:
    Nov 12, 2008
    Messages:
    24
    Likes Received:
    0
    The same thing just happened to me.
     
  10. FeebleOldMan

    FeebleOldMan Loaded Pockets

    Joined:
    Feb 10, 2009
    Messages:
    671
    Likes Received:
    11
    Hmm.. so the show unread posts is not updating properly? Could you please list out the following info:

    1. Which Internet browser and version you are using,
    2. All plug-ins for the browser (if applicable), and
    3. Which operating system you are using.
     
  11. Synaptic Misfire
    • In Omnia Paratus

    Synaptic Misfire Loaded Pockets

    Joined:
    Nov 15, 2008
    Messages:
    1,228
    Likes Received:
    246
    Firefox v3.0
    No addons
    Windows XP SP2
     
  12. FeebleOldMan

    FeebleOldMan Loaded Pockets

    Joined:
    Feb 10, 2009
    Messages:
    671
    Likes Received:
    11
    I'm thinking that it might be corrupt session cookies. Try this and post back if you encounter the same problem again:

    _________________________________________________
    Firefox (without addons i.e. noscript / cslite etc) on XP SP2
    1. Make sure your FF is updated (currently v3.0.10 @ 27th April 2009), if not, update it via "Help / Check for Updates..."

    2. Make sure you are accepting cookies from edcforums.com. Select "Tools / Options..." and click on the "Privacy" tab. Check that the "Accept cookies from sites" is ticked, and "Keep until:" is set to "they expire". Also, check that you didn't accidentally block "edcforums.com" in the "Exceptions..." menu.

    3. Go to edcforums.com and log out (after you're done perusing the forums of course ;D).

    4. Press Ctrl+Shift+Del to bring up the "Clear Private Data" window, and make sure at least the "Cache", "Cookies" and "Authenticated Sessions" are ticked.

    5. Close and Restart FF.

    6. Log back in to edcforums.com.
    _________________________________________________
     
  13. JonSidneyB
    • Administrator

    JonSidneyB Uber Prepared
    Staff Member

    Joined:
    Mar 28, 2006
    Messages:
    21,161
    Likes Received:
    12,086
    I didn't have time to look at this. In 2 hours from now I will have been working on things related to the forum for 48 hours and I am beat. I have not been able to address some issues as my focus has been on the survival of the forum rather that all the fixes. I am actually quite surprised this forum is still here but we are still not out of the woods.
     
  14. bltkmt

    bltkmt Loaded Pockets

    Joined:
    Oct 22, 2007
    Messages:
    871
    Likes Received:
    157
    I have had this same issue since coming to this site. My understanding was that since you did not log off, the site thinks you have been on continuously...hence no new posts since last visit? My workaround has been to log off each time, or only log in with a limited duration (60 mins)...not a great solution, but it works.
     
  15. captainamerica

    captainamerica Loaded Pockets

    Joined:
    Apr 21, 2009
    Messages:
    234
    Likes Received:
    92
    As an update I'm not getting the same problems on my home PC like at work. Noth sent me a PM and I think he's right about the web browser at work being the issue; not to mention the lack of formally signing out. I return to work again on Monday and will be watching in the days to come. Thanks everyone for their help and I'll post back if something further develops.
     
  16. Stelth

    Stelth Banned

    Joined:
    Jun 27, 2008
    Messages:
    430
    Likes Received:
    1
    I never log out and my unread posts are always up to date. I use a PC at home which runs IE and at work a Mac that uses Safari.
     
  17. FeebleOldMan

    FeebleOldMan Loaded Pockets

    Joined:
    Feb 10, 2009
    Messages:
    671
    Likes Received:
    11
    I never log out either and just close the tabs when I am done, and have no problems.

    I Ctrl+Click whichever posts I am interested in in the "Show new replies to your posts" first, then click "Mark as read" to remove the others I'm not interested in reading. Then I click on "Show unread posts since last visit" and Ctrl+Click from back to front (i.e. if there are 3 pages worth of unread stuff, I start from page 3) before clicking on "Mark as read" to clear everything else. Doing this, I can even press refresh and it'll start listing out new posts I haven't read in the "same visit".
     
  18. noth

    noth Loaded Pockets

    Joined:
    Sep 16, 2008
    Messages:
    145
    Likes Received:
    1
    Exacty!