1. Are you a current member with account or password issues?

    Please visit following page for more information

    Dismiss Notice

JetBeam RRT-0 Question

Discussion in 'Flashlights & Other Illumination Devices' started by Jedi Knife, Aug 25, 2011.

  1. Jedi Knife

    Jedi Knife Loaded Pockets

    Joined:
    Aug 8, 2007
    Messages:
    456
    Likes Received:
    9
    I just received this light a day ago, and it is phenomenal! I was wondering about the light control ring, however. Mine is very smooth, and it doesn't rattle or is not loose, but I have noticed that it has a little up/down play when I adj. it. I am almost positive it has to have a little play like this in order to function so smoothly, but I am interested in hearing from other RRT owners out there to see if they have noticed similar characteristics in their lights.
    Also, how has the control ring setup held up in general; has anyone had any trouble with theirs?
    Thanks for any input!
     
  2. tonester

    tonester Loaded Pockets

    Joined:
    Apr 1, 2009
    Messages:
    2,231
    Likes Received:
    786
    mine has a little play too, nothing noticeable though. mine is holding up fine. i really dont edc it on my person, it is my light for my edc bag since it can use either AA's or cr123's. it really is an awesome light, perfect for the BOB or edc bag.
     
  3. Jedi Knife

    Jedi Knife Loaded Pockets

    Joined:
    Aug 8, 2007
    Messages:
    456
    Likes Received:
    9
    Thanks for the input, Tonester. This light has amazing throw; it hangs with my Olight Warrior R5 w/18650, except for a little less spill. Amazing!
    Now, has anyone tried a 14500 in AA setup, and would it even be OK to run it this way? I'm thinking YES since voltage will comply with manufacturers specs, but I'd like to hear from anyone who has tried this firsthand.
     
  4. Buffalohump

    Buffalohump Loaded Pockets

    Joined:
    Jul 21, 2006
    Messages:
    571
    Likes Received:
    5
    I dont notice any play in mine... excellent light. I run it on one AW black cell. It cranks! Did you find the strobe yet? I only found it after I'd owned mine for a while...